aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 68ff260d..43268291 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -1,9 +1,9 @@
[package]
name = "helix-term"
-version = "0.4.1"
+version = "0.5.0"
description = "A post-modern text editor."
authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
-edition = "2018"
+edition = "2021"
license = "MPL-2.0"
categories = ["editor", "command-line-utilities"]
repository = "https://github.com/helix-editor/helix"
@@ -21,10 +21,10 @@ name = "hx"
path = "src/main.rs"
[dependencies]
-helix-core = { version = "0.4", path = "../helix-core" }
-helix-view = { version = "0.4", path = "../helix-view" }
-helix-lsp = { version = "0.4", path = "../helix-lsp" }
-helix-dap = { version = "0.4", path = "../helix-dap" }
+helix-core = { version = "0.5", path = "../helix-core" }
+helix-view = { version = "0.5", path = "../helix-view" }
+helix-lsp = { version = "0.5", path = "../helix-lsp" }
+helix-dap = { version = "0.5", path = "../helix-dap" }
anyhow = "1"
once_cell = "1.8"
@@ -32,7 +32,7 @@ once_cell = "1.8"
tokio = { version = "1", features = ["rt", "rt-multi-thread", "io-util", "io-std", "time", "process", "macros", "fs", "parking_lot"] }
num_cpus = "1"
tui = { path = "../helix-tui", package = "helix-tui", default-features = false, features = ["crossterm"] }
-crossterm = { version = "0.21", features = ["event-stream"] }
+crossterm = { version = "0.22", features = ["event-stream"] }
signal-hook = "0.3"
tokio-stream = "0.1"
futures-util = { version = "0.3", features = ["std", "async-await"], default-features = false }
@@ -45,10 +45,10 @@ log = "0.4"
# File picker
fuzzy-matcher = "0.3"
ignore = "0.4"
-# shellexpand = "2.1"
-# dirs-next = "2.0"
# markdown doc rendering
pulldown-cmark = { version = "0.8", default-features = false }
+# file type detection
+content_inspector = "0.2.4"
# config
toml = "0.5"