aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml17
1 files changed, 13 insertions, 4 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index ea4d5b55..0ab6209e 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -10,13 +10,22 @@ edition = "2018"
name = "hx"
path = "src/main.rs"
-# [[bin]]
-# name = "line"
-# path = "src/line.rs"
+[[bin]]
+name = "line"
+path = "src/line.rs"
[dependencies]
# termwiz = { git = "https://github.com/wez/wezterm", features = ["widgets"] }
-termwiz = { path = "../../wezterm/termwiz", default-features = false, features = ["widgets"] }
+# termwiz = { path = "../../wezterm/termwiz", default-features = false, features = ["widgets"] }
+
anyhow = "1.0.31"
argh = "0.1.3"
helix-core = { path = "../helix-core" }
+# crossterm = { version = "0.17.5", features = ["event-stream"] }
+crossterm = { git = "https://github.com/crossterm-rs/crossterm", branch = "mio-update", features = ["event-stream"] }
+
+futures = { version = "0.3.5", default-features = false, features = ["std"] }
+# futures-timer = "3.0.2"
+smol = "0.1.10"
+num_cpus = "1.13.0"
+piper = "0.1.2"