aboutsummaryrefslogtreecommitdiff
path: root/helix-view/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'helix-view/Cargo.toml')
-rw-r--r--helix-view/Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/helix-view/Cargo.toml b/helix-view/Cargo.toml
index 593f00e0..7f18e9a2 100644
--- a/helix-view/Cargo.toml
+++ b/helix-view/Cargo.toml
@@ -4,6 +4,10 @@ version = "0.2.0"
authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
edition = "2018"
license = "MPL-2.0"
+description = "UI abstractions for use in backends"
+categories = ["editor"]
+repository = "https://github.com/helix-editor/helix"
+homepage = "https://helix-editor.com"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -13,8 +17,8 @@ default = ["term"]
[dependencies]
anyhow = "1"
-helix-core = { path = "../helix-core" }
-helix-lsp = { path = "../helix-lsp"}
+helix-core = { version = "0.2", path = "../helix-core" }
+helix-lsp = { version = "0.2", path = "../helix-lsp"}
# Conversion traits
tui = { path = "../helix-tui", package = "helix-tui", default-features = false, features = ["crossterm"], optional = true }
@@ -23,6 +27,7 @@ once_cell = "1.8"
url = "2"
tokio = { version = "1", features = ["full"] }
+futures-util = { version = "0.3", features = ["std", "async-await"], default-features = false }
slotmap = "1"