aboutsummaryrefslogtreecommitdiff
path: root/helix-view/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'helix-view/Cargo.toml')
-rw-r--r--helix-view/Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/helix-view/Cargo.toml b/helix-view/Cargo.toml
index cadbbdbd..9c3c23ff 100644
--- a/helix-view/Cargo.toml
+++ b/helix-view/Cargo.toml
@@ -9,20 +9,18 @@ categories = ["editor"]
repository = "https://github.com/helix-editor/helix"
homepage = "https://helix-editor.com"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
[features]
-term = ["tui", "crossterm"]
-default = ["term"]
+default = []
+term = ["crossterm"]
[dependencies]
+bitflags = "1.0"
anyhow = "1"
helix-core = { version = "0.2", path = "../helix-core" }
helix-lsp = { version = "0.2", path = "../helix-lsp"}
+crossterm = { version = "0.20", optional = true }
# Conversion traits
-tui = { path = "../helix-tui", package = "helix-tui", default-features = false, features = ["crossterm"], optional = true }
-crossterm = { version = "0.20", features = ["event-stream"], optional = true }
once_cell = "1.8"
url = "2"
@@ -39,3 +37,6 @@ toml = "0.5"
log = "~0.4"
which = "4.1"
+
+[dev-dependencies]
+helix-tui = { path = "../helix-tui" }