aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 9c63ab9f..be1b20d0 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,12 +1,15 @@
-{ pkgs ? import <nixpkgs> {} }:
+{ stdenv, pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
nativeBuildInputs = with pkgs; [
(rust-bin.nightly.latest.rust.override { extensions = ["rust-src"]; })
lld_10
- # pkgconfig
+ stdenv.cc.cc.lib
+ # pkg-config
];
RUSTFLAGS = "-C link-arg=-fuse-ld=lld -C target-cpu=native";
RUST_BACKTRACE = "1";
+ # https://github.com/rust-lang/rust/issues/55979
+ LD_LIBRARY_PATH="${stdenv.cc.cc.lib}/lib64:$LD_LIBRARY_PATH";
}