aboutsummaryrefslogtreecommitdiff
path: root/entries/jlouis/shell.nix
diff options
context:
space:
mode:
authorBraxton Hall2022-10-25 19:55:05 +0000
committerGitHub2022-10-25 19:55:05 +0000
commit51cfdff65b200f3cb16688b79720a1ab57d2db02 (patch)
tree3d83a52d4d895990b9b3b91ebaae5e78e938c51d /entries/jlouis/shell.nix
parent9375f87d202403e93ea4196e60de24fd9a9ea065 (diff)
parent562c485e2e7bd5330e1ccbeb9fd2dc87e3255f9f (diff)
Merge pull request #43 from jlouis/jlouis-implementation
Provide a fib implementation for jlouis
Diffstat (limited to 'entries/jlouis/shell.nix')
-rw-r--r--entries/jlouis/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/entries/jlouis/shell.nix b/entries/jlouis/shell.nix
new file mode 100644
index 0000000..d5e27a3
--- /dev/null
+++ b/entries/jlouis/shell.nix
@@ -0,0 +1,11 @@
+let
+ pkgs = import <nixpkgs> {};
+ # choose the ocaml version you want to use
+ ocamlPackages = pkgs.ocaml-ng.ocamlPackages_4_14;
+in
+pkgs.mkShell {
+ # build tools
+ nativeBuildInputs = with ocamlPackages; [ ocaml utop findlib dune_3 ocaml-lsp ppx_inline_test ];
+ # dependencies
+ buildInputs = with ocamlPackages; [ ocamlgraph ];
+}