aboutsummaryrefslogtreecommitdiff
path: root/entries/jlouis/shell.nix
diff options
context:
space:
mode:
authorJesper Louis Andersen2022-10-25 16:13:39 +0000
committerJesper Louis Andersen2022-10-25 16:13:39 +0000
commit5b229b11cb63e77925c3d6af3ad8028e1ae7efc2 (patch)
treecf7c90c87c2c4dcd7a8d689dc55e5e0db55d57eb /entries/jlouis/shell.nix
parent9375f87d202403e93ea4196e60de24fd9a9ea065 (diff)
Provide a fib implementation for jlouis
Most of the entry is pure build-scaffolding. The meat is in a single file, which is then referenced in people.json.
Diffstat (limited to 'entries/jlouis/shell.nix')
-rw-r--r--entries/jlouis/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/entries/jlouis/shell.nix b/entries/jlouis/shell.nix
new file mode 100644
index 0000000..d5e27a3
--- /dev/null
+++ b/entries/jlouis/shell.nix
@@ -0,0 +1,11 @@
+let
+ pkgs = import <nixpkgs> {};
+ # choose the ocaml version you want to use
+ ocamlPackages = pkgs.ocaml-ng.ocamlPackages_4_14;
+in
+pkgs.mkShell {
+ # build tools
+ nativeBuildInputs = with ocamlPackages; [ ocaml utop findlib dune_3 ocaml-lsp ppx_inline_test ];
+ # dependencies
+ buildInputs = with ocamlPackages; [ ocamlgraph ];
+}