aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMichael Davis2022-02-13 16:42:18 +0000
committerBlaž Hrastnik2022-03-10 08:31:57 +0000
commiteeb3f8e9639e68ea2d54a6be26d45543d01057f6 (patch)
treeb6847b9e8edb0422f6d88bf84f8a6dddb036f373 /Cargo.toml
parentc1f90a127b972c8b41b0d24dcacb3bdd480be9c5 (diff)
migrate helix-syntax crate into helix-core and helix-term
helix-syntax mostly existed for the sake of the build task which checks and compiles the submodules. Since we won't be relying on that process anymore, it doesn't end up making much sense to have a very thin crate just for some functions that we could port to helix-core. The remaining build-related code is moved to helix-term which will be able to provide grammar builds through the --build-grammars CLI flag.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 0 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 31088f98..0847e6ba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,7 +4,6 @@ members = [
"helix-view",
"helix-term",
"helix-tui",
- "helix-syntax",
"helix-lsp",
"helix-dap",
"xtask",
@@ -14,10 +13,6 @@ default-members = [
"helix-term"
]
-# Build helix-syntax in release mode to make the code path faster in development.
-# [profile.dev.package."helix-syntax"]
-# opt-level = 3
-
[profile.dev]
split-debuginfo = "unpacked"