aboutsummaryrefslogtreecommitdiff
path: root/helix-core/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-09-06 04:18:16 +0000
committerBlaž Hrastnik2021-09-06 04:21:53 +0000
commit3cb95be452491a72d18c98ebc619b0d2abb1b746 (patch)
tree3881ee13510c703ca213cdaaa16c2b25049d6fc5 /helix-core/Cargo.toml
parent57ed5180e0e1af3b3ddcb478c4a6d6ecd969cd40 (diff)
Update tree-sitter to 0.20
0.20 includes querying improvements, we no longer have to convert fragments to strings but can return an iterator of chunks instead.
Diffstat (limited to 'helix-core/Cargo.toml')
-rw-r--r--helix-core/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/helix-core/Cargo.toml b/helix-core/Cargo.toml
index 8c83816c..5d2db642 100644
--- a/helix-core/Cargo.toml
+++ b/helix-core/Cargo.toml
@@ -22,7 +22,7 @@ unicode-segmentation = "1.8"
unicode-width = "0.1"
unicode-general-category = "0.4"
# slab = "0.4.2"
-tree-sitter = "0.19"
+tree-sitter = "0.20"
once_cell = "1.8"
arc-swap = "1"
regex = "1"