aboutsummaryrefslogtreecommitdiff
path: root/helix-term/Cargo.toml
diff options
context:
space:
mode:
authorLeoi Hung Kin2021-09-21 16:03:12 +0000
committerGitHub2021-09-21 16:03:12 +0000
commit9456d5c1a258e71bbb7e391dec8c3efb819e2d7d (patch)
tree11ecd447d52866168082d06701fc1cfb8612bea4 /helix-term/Cargo.toml
parenta512f48e4574f7465dceecb89c4dbbfa9e21ff6f (diff)
Initial implementation of global search (#651)
* initial implementation of global search * use tokio::sync::mpsc::unbounded_channel instead of Arc, Mutex, Waker poll_fn * use tokio_stream::wrappers::UnboundedReceiverStream to collect all search matches * regex_prompt: unified callback; refactor * global search doc
Diffstat (limited to 'helix-term/Cargo.toml')
-rw-r--r--helix-term/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/helix-term/Cargo.toml b/helix-term/Cargo.toml
index 57d592cc..fe4da96e 100644
--- a/helix-term/Cargo.toml
+++ b/helix-term/Cargo.toml
@@ -55,5 +55,10 @@ toml = "0.5"
serde_json = "1.0"
serde = { version = "1.0", features = ["derive"] }
+# ripgrep for global search
+grep-regex = "0.1.9"
+grep-searcher = "0.1.8"
+tokio-stream = "0.1.7"
+
[target.'cfg(not(windows))'.dependencies] # https://github.com/vorner/signal-hook/issues/100
signal-hook-tokio = { version = "0.3", features = ["futures-v0_3"] }