aboutsummaryrefslogtreecommitdiff
path: root/helix-tui/Cargo.toml
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-05-09 08:52:55 +0000
committerBlaž Hrastnik2021-05-09 08:52:55 +0000
commit35606a3daa7ee273845a12f3e03728e0ae23928e (patch)
tree643684eaff6627dbebc4156d33fdb541bf87bbd9 /helix-tui/Cargo.toml
parent6c705f09e88a4b63c4ed854bc9e956b0539ca8af (diff)
Inline tui as helix-tui fork.
We only rely on some of the rendering primitives and implement our Cursive-style compositor on top.
Diffstat (limited to 'helix-tui/Cargo.toml')
-rw-r--r--helix-tui/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/helix-tui/Cargo.toml b/helix-tui/Cargo.toml
new file mode 100644
index 00000000..badefe4c
--- /dev/null
+++ b/helix-tui/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "helix-tui"
+version = "0.1.0"
+authors = ["Blaž Hrastnik <blaz@mxxn.io>"]
+description = """
+A library to build rich terminal user interfaces or dashboards
+"""
+edition = "2018"
+
+[features]
+default = ["crossterm"]
+
+[dependencies]
+bitflags = "1.0"
+cassowary = "0.3"
+unicode-segmentation = "1.2"
+unicode-width = "0.1"
+crossterm = { version = "0.19", optional = true }
+serde = { version = "1", "optional" = true, features = ["derive"]}