aboutsummaryrefslogtreecommitdiff
path: root/helix-view/Cargo.toml
diff options
context:
space:
mode:
authorgavynriebau2023-01-16 07:13:48 +0000
committerGitHub2023-01-16 07:13:48 +0000
commitcce19713fb970df1a96be7e76e3217e4e50efc42 (patch)
tree0c6b22c0ef42aa44d9f651931eebd83a299fa45e /helix-view/Cargo.toml
parentb6331394a3f341ad21f8fad3e6e0b93becda9ce5 (diff)
Fix for lost clipboard contents (#5424) (#5426)
* Fix for lost clipboard contents (#5424) * PR feedback: Call "setsid" for all unix systems * PR Feedback: Only install libc for unix targets
Diffstat (limited to 'helix-view/Cargo.toml')
-rw-r--r--helix-view/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/helix-view/Cargo.toml b/helix-view/Cargo.toml
index e7a20496..7d130317 100644
--- a/helix-view/Cargo.toml
+++ b/helix-view/Cargo.toml
@@ -48,5 +48,8 @@ which = "4.2"
[target.'cfg(windows)'.dependencies]
clipboard-win = { version = "4.5", features = ["std"] }
+[target.'cfg(unix)'.dependencies]
+libc = "0.2"
+
[dev-dependencies]
helix-tui = { path = "../helix-tui" }