aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorBlaž Hrastnik2021-01-19 06:54:51 +0000
committerBlaž Hrastnik2021-01-19 06:54:51 +0000
commitf1539cc86680935a0b2a5bbd16c64b110687cdf7 (patch)
treed6d723aed8cc8248bd431f774a279dc1f38210da /shell.nix
parent22e1692adcf388fce358196bc817a9f6d394a29e (diff)
Add a nix flake with the development environment.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..f8f65093
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShell {
+ nativeBuildInputs = with pkgs; [
+ rust-bin.nightly.latest.rust
+ lld_10
+ # pkgconfig
+ ];
+ RUSTFLAGS = "-C link-arg=-fuse-ld=lld";
+ RUST_BACKTRACE = "1";
+}
+