aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..f8f65093
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,12 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShell {
+ nativeBuildInputs = with pkgs; [
+ rust-bin.nightly.latest.rust
+ lld_10
+ # pkgconfig
+ ];
+ RUSTFLAGS = "-C link-arg=-fuse-ld=lld";
+ RUST_BACKTRACE = "1";
+}
+